<!doctype html>
<html lang="fr-FR">
<head>
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@edasfr">
<meta name="twitter:site" content="@edasfr">
<meta name="twitter:title" content="Dis tonton, comment &ccedil;a fonctionne la s&eacute;curit&eacute; d&rsquo;un gestionnaire de mots de passe&#8239;? &mdash; Introduction cryptographique">
<meta name="twitter:description" content="Il y a peut-être des erreurs, probablement des mauvais termes, certainement des fautes ou mauvaises formulations. Vous êtes bienvenus à participer en proposant des corrections.L&#039;idée de b">
<meta name="twitter:image" content="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d’écran-2019-09-22-à-16.30.38-1-1024x340.png">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<title>Dis tonton, comment ça fonctionne la sécurité d&rsquo;un gestionnaire de mots de passe ? — Introduction cryptographique &#8211; Carnet de notes</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Carnet de notes &raquo; Flux" href="https://n.survol.fr/feed" />
<link rel="alternate" type="application/rss+xml" title="Carnet de notes &raquo; Flux des commentaires" href="https://n.survol.fr/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Carnet de notes &raquo; Dis tonton, comment &ccedil;a fonctionne la s&eacute;curit&eacute; d&rsquo;un gestionnaire de mots de passe&#8239;? &mdash; Introduction cryptographique Flux des commentaires" href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique/feed" />
<link rel="alternate" type="application/stream+json" title="Carnet de notes &raquo; Activity-Streams Feed" href="https://n.survol.fr/feed/as1" />
<link rel="alternate" type="application/stream+json" title="Carnet de notes &raquo; Activity-Streams Comments Feed " href="https://n.survol.fr/comments/feed/as1" />
		<link rel="alternate" type="application/stream+json" title="Carnet de notes &raquo; Dis tonton, comment &ccedil;a fonctionne la s&eacute;curit&eacute; d&rsquo;un gestionnaire de mots de passe&#8239;? &mdash; Introduction cryptographique Activity-Streams Comments Feed" href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique/feed/as1" />
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/n.survol.fr\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://n.survol.fr/wp-includes/css/dist/block-library/style.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://n.survol.fr/wp-includes/css/dist/block-library/theme.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='twentynineteen-style-css'  href='https://n.survol.fr/wp-content/themes/twentynineteen/style.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentynineteen-print-style-css'  href='https://n.survol.fr/wp-content/themes/twentynineteen/print.css?ver=1.2' type='text/css' media='print' />
<link rel='https://api.w.org/' href='https://n.survol.fr/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://n.survol.fr/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://n.survol.fr/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Quels cr&eacute;dits&#8239;?' href='https://n.survol.fr/n/quels-credits' />
<meta name="generator" content="WordPress 5.0.3" />
<link rel="canonical" href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique" />
<link rel='shortlink' href='https://n.survol.fr/?p=19406' />
<link rel="alternate" type="application/json+oembed" href="https://n.survol.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fn.survol.fr%2Fn%2Fdis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique" />
<link rel="alternate" type="text/xml+oembed" href="https://n.survol.fr/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fn.survol.fr%2Fn%2Fdis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique&#038;format=xml" />
<link rel="pingback" href="https://n.survol.fr/xmlrpc.php"><link rel="webmention" href="https://n.survol.fr/wp-json/webmention/1.0/endpoint" />
<link rel="http://webmention.org/" href="https://n.survol.fr/wp-json/webmention/1.0/endpoint" />
		<style type="text/css" id="wp-custom-css">
			#masthead { padding-bottom: 0 }		</style>
	</head>

<body class="post-template-default single single-post postid-19406 single-format-standard wp-embed-responsive singular image-filters-enabled">

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Aller au contenu</a>

		<header id="masthead" class="site-header">

			<div class="site-branding-container">
				<div class="site-branding">

								<p class="site-title"><a href="https://n.survol.fr/" rel="home">Carnet de notes</a></p>
			
				<p class="site-description">
				n.survol.fr			</p>
			</div><!-- .site-branding -->
			</div><!-- .layout-wrap -->

					</header><!-- #masthead -->

	<div id="content" class="site-content">

	<section id="primary" class="content-area">
		<main id="main" class="site-main">

			
<article id="post-19406" class="post-19406 post type-post status-publish format-standard hentry category-geek category-securite-informatique category-technique entry">
		<header class="entry-header">
		
<h1 class="entry-title">Dis tonton, comment &ccedil;a fonctionne la s&eacute;curit&eacute; d&rsquo;un gestionnaire de mots de passe&#8239;? &mdash; Introduction cryptographique</h1>
<div class="entry-meta">
	<span class="byline"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 12c2.21 0 4-1.79 4-4s-1.79-4-4-4-4 1.79-4 4 1.79 4 4 4zm0 2c-2.67 0-8 1.34-8 4v2h16v-2c0-2.66-5.33-4-8-4z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Publié par</span><span class="author vcard"><a class="url fn n" href="https://n.survol.fr/n/author/edaspet">Éric</a></span></span>	<span class="posted-on"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><defs><path id="a" d="M0 0h24v24H0V0z"></path></defs><clipPath id="b"><use xlink:href="#a" overflow="visible"></use></clipPath><path clip-path="url(#b)" d="M12 2C6.5 2 2 6.5 2 12s4.5 10 10 10 10-4.5 10-10S17.5 2 12 2zm4.2 14.2L11 13V7h1.5v5.2l4.5 2.7-.8 1.3z"></path></svg><a href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique" rel="bookmark"><time class="entry-date published" datetime="2019-09-23T12:51:10+02:00">23 septembre 2019</time><time class="updated" datetime="2019-09-23T15:10:00+02:00">23 septembre 2019</time></a></span>	<span class="comment-count">
				<span class="comments-link"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.99 4c0-1.1-.89-2-1.99-2H4c-1.1 0-2 .9-2 2v12c0 1.1.9 2 2 2h14l4 4-.01-18z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><a href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique#respond">Laisser un commentaire<span class="screen-reader-text"> sur Dis tonton, comment &ccedil;a fonctionne la s&eacute;curit&eacute; d&rsquo;un gestionnaire de mots de passe&#8239;? &mdash; Introduction cryptographique</span></a></span>	</span>
	</div><!-- .meta-info -->
	</header>
	
	<div class="entry-content">
		<p><em>Il y a peut-&ecirc;tre des erreurs, probablement des mauvais termes, certainement des fautes ou mauvaises formulations. Vous &ecirc;tes bienvenus &agrave; participer en proposant des corrections.</em></p>



<hr class="wp-block-separator"><p>L&rsquo;id&eacute;e de base&nbsp;: Tous les mots de passe sont chiffr&eacute;s. Personne d&rsquo;autre que vous ne peut les relire sans votre accord. Ni le serveur sur lequel vous les envoyez, ni quelqu&rsquo;un qui a acc&egrave;s au disque o&ugrave; vous les stockez, ni quelqu&rsquo;un qui a ponctuellement acc&egrave;s &agrave; votre poste de travail.</p>



<h3>Chiffrer c&rsquo;est simple. </h3>



<p>Pour chiffrer on a le choix. On va s&eacute;parer deux cat&eacute;gories principales de chiffrement&nbsp;: les chiffrements sym&eacute;triques et les asym&eacute;triques.</p>



<p>La plupart des gestionnaires de mots de passe ont choisi un <a href="https://fr.wikipedia.org/wiki/Cryptographie_sym%C3%A9trique">chiffrement sym&eacute;trique</a> (une seule clef secr&egrave;te qui sert &agrave; la fois &agrave; chiffrer et &agrave; d&eacute;chiffrer). C&rsquo;est simple &agrave; g&eacute;rer, rapide &agrave; l&rsquo;ex&eacute;cution, et il n&rsquo;y a pas besoin de clef de grande taille. Tous ceux que j&rsquo;ai vu utilisent de l&rsquo;<a href="https://fr.wikipedia.org/wiki/Advanced_Encryption_Standard">AES</a> avec une clef de 256 bits. Au moins pour Bitwarden et Keepass, c&rsquo;est le mode <a href="https://fr.wikipedia.org/wiki/Mode_d%27op%C3%A9ration_(cryptographie)#Encha.C3.AEnement_des_blocs_:_.C2.AB_Cipher_Block_Chaining_.C2.BB_.28CBC.29">CBC</a>, et un contr&ocirc;le <a href="https://fr.wikipedia.org/wiki/Keyed-hash_message_authentication_code">HMAC</a> avec <a href="https://fr.wikipedia.org/wiki/SHA-2#SHA-256">SHA256</a> comme fonction de hachage (mais vous pouvez ignorer tous ces d&eacute;tails s&rsquo;ils ne vous disent rien).</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-22-a%CC%80-16.30.38-1-1024x340.png" alt="" class="wp-image-19418" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-22-a&#768;-16.30.38-1-1024x340.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-22-a&#768;-16.30.38-1-300x100.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-22-a&#768;-16.30.38-1-768x255.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-22-a&#768;-16.30.38-1.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>J&rsquo;ai dit &laquo;&nbsp;la plupart des gestionnaires de mots de passe&nbsp;&raquo;. Un projet au moins a fait un choix diff&eacute;rent. L&rsquo;outil <em><a href="https://www.passwordstore.org/">pass</a></em> utilise un <a href="https://fr.wikipedia.org/wiki/Cryptographie_asym%C3%A9trique">chiffrement asym&eacute;trique</a> (une clef publique et une clef priv&eacute;e, l&rsquo;une sert &agrave; chiffrer et l&rsquo;autre &agrave; d&eacute;chiffrer). Plus exactement, ils utilisent l&rsquo;outil <a href="https://gnupg.org/">GnuPG</a>. M&ecirc;me si le choix de la clef est libre, par d&eacute;faut on y utilise g&eacute;n&eacute;ralement une clef <a href="https://fr.wikipedia.org/wiki/Chiffrement_RSA">RSA</a> de 2048 bits. Pass a fait ce choix en consid&eacute;rant le partage de mots de passes comme <em>la</em> fonctionnalit&eacute; principale. On verra pourquoi quand on parlera partage. Entre temps on va se concentrer sur ceux qui font du chiffrement sym&eacute;trique.</p>



<p>Dans les deux cas, on est l&agrave; dans de l&rsquo;ultra-standard au niveau cryptographie. Je serais &eacute;tonn&eacute; de voir autre chose ailleurs (et c&rsquo;est une bonne chose).</p>



<h3>Une clef&#8239;? quelle clef&#8239;?</h3>



<p>Ok, nos mots de passe sont chiffr&eacute;s mais o&ugrave; est la clef&#8239;?</p>



<p>Impossible de demander &agrave; l&rsquo;utilisateur de se rappeler une clef de 256 bits. Ce serait plus de 40 signes entre minuscules, majuscules, chiffres et caract&egrave;res sp&eacute;ciaux. M&ecirc;me avec une tr&egrave;s bonne m&eacute;moire, ce serait ing&eacute;rable &agrave; l&rsquo;usage.</p>



<p>Stocker la clef de chiffrement en clair sur le disque n&rsquo;est pas beaucoup mieux. Ce serait comme avoir coffre-fort haute s&eacute;curit&eacute; dont on cache la clef sous le paillasson. </p>



<p>Ce qu&rsquo;on demande &agrave; l&rsquo;utilisateur c&rsquo;est un mot de passe principal. Vu qu&rsquo;il va permettre de d&eacute;chiffrer tous les autres, on va l&rsquo;appeler &laquo;&nbsp;mot de passe ma&icirc;tre&nbsp;&raquo;. Il faut qu&rsquo;il soit assez long et complexe pour &eacute;viter qu&rsquo;un tiers ne puisse le deviner ou le trouver en essayant toutes les combinaisons une &agrave; une, mais assez court pour pouvoir s&rsquo;en rappeler et le taper sans erreur. </p>



<p>Le mot de passe ma&icirc;tre ne chiffre rien lui-m&ecirc;me. Accompagn&eacute; d&rsquo;autres param&egrave;tres, il sert &agrave; calculer une clef de taille suffisante qui, elle, servira au chiffrement d&eacute;crit plus haut et qu&rsquo;on va appeler &laquo;&nbsp;clef ma&icirc;tresse&nbsp;&raquo;. La fonction qui fait cette op&eacute;ration est dite <a href="https://fr.wikipedia.org/wiki/Fonction_de_d%C3%A9rivation_de_cl%C3%A9">fonction de d&eacute;rivation de clef</a>.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-15.09.43-1024x318.png" alt="" class="wp-image-19463" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.43-1024x318.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.43-300x93.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.43-768x238.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.43.png 1482w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>Bitwarden utilise le tr&egrave;s classique <a href="https://fr.wikipedia.org/wiki/PBKDF2">PBKDF2</a> avec un hachage SHA256. Pour faire simple on prend le mot de passe, on le m&eacute;lange &agrave; une cha&icirc;ne al&eacute;atoire (stock&eacute;e quelque part pour r&eacute;utiliser la m&ecirc;me &agrave; chaque fois), et on op&egrave;re la fonction de hachage pr&eacute;vue. Normalement &ccedil;a suffit pour avoir un r&eacute;sultat consid&eacute;r&eacute; comme relativement al&eacute;atoire et impossible &agrave; remonter en sens inverse. </p>



<p>En pratique on cherche aussi &agrave; ralentir quelqu&rsquo;un qui chercherait &agrave; tester tous les mots de passe possibles un &agrave; un. Pour &ccedil;a on va faire plusieurs it&eacute;rations, o&ugrave; le mot de passe en entr&eacute;e d&rsquo;une it&eacute;ration correspond au r&eacute;sultat de l&rsquo;it&eacute;ration pr&eacute;c&eacute;dente. Plus on fait d&rsquo;it&eacute;rations, plus on consid&egrave;re qu&rsquo;il sera difficile et co&ucirc;teux de tester toutes les combinaisons. Ici on consid&egrave;re le r&eacute;sultat comme assez confortable &agrave; partir de 100.000 it&eacute;rations.</p>



<p>Keepass utilise lui une fonction plus r&eacute;cente et consid&eacute;r&eacute;e comme plus robuste aux possibilit&eacute;s des mat&eacute;riels actuels&nbsp;: <a href="https://fr.wikipedia.org/wiki/Argon2">Argon2</a>.</p>



<p>L&agrave; aussi tout est tr&egrave;s classique. Je n&rsquo;ai pas regard&eacute; tous les gestionnaires de mots de passe mais je serais &eacute;tonn&eacute; de trouver autre chose que ces deux solutions standards.</p>



<h3>On r&eacute;sume</h3>



<p>&Agrave; l&rsquo;ouverture le gestionnaire de mots de passe vous demande votre mot de passe ma&icirc;tre. &Agrave; partir de ce mot de passe et de param&egrave;tres pr&eacute;d&eacute;termin&eacute;s, il utilise une fonction de d&eacute;rivation de clef et en sort une clef maitresse.</p>



<p>C&rsquo;est cette clef maitresse qui permet de chiffrer ou d&eacute;chiffrer vos mots de passe. Celui qui n&rsquo;a pas acc&egrave;s &agrave; votre clef ne pourra rien faire des mots de passe chiffr&eacute;s sur le disque.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-15.09.04-1024x585.png" alt="" class="wp-image-19461" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.04-1024x585.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.04-300x171.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.04-768x438.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.09.04.png 1482w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><h3>S&eacute;curit&eacute;</h3>



<p>&Agrave; l&rsquo;ouverture, le gestionnaire de mot de passe vous demandera votre mot de passe ma&icirc;tre que pour calculer la clef ma&icirc;tresse &agrave; l&rsquo;aide d&rsquo;une fonction de d&eacute;rivation de clef. Une fois ceci fait, il garde la clef ma&icirc;tresse en m&eacute;moire et oublie le reste. Quoi qu&rsquo;il se passe, personne ne conna&icirc;tra votre mot de passe ma&icirc;tre.</p>



<p>Le logiciel utilise cette clef ma&icirc;tresse pour chiffrer et d&eacute;chiffrer vos mots de passe. Cette clef ma&icirc;tresse n&rsquo;est jamais &eacute;crite nulle part. La plupart des gestionnaires de mots de passe oublieront volontairement cette clef en m&eacute;moire apr&egrave;s un certain temps d&rsquo;inactivit&eacute;, ou &agrave; la mise en veille de votre poste de travail. L&rsquo;id&eacute;e c&rsquo;est de limiter le risque de laisser qui que ce soit d&rsquo;autre que vous y avoir acc&egrave;s. Dans ces cas l&agrave;, on vous invitera &agrave; saisir de nouveau votre mot de passe ma&icirc;tre pour retrouver la clef oubli&eacute;e.</p>



<p>Une fois la clef ma&icirc;tresse hors de la m&eacute;moire, vous n&rsquo;avez que des blocs chiffr&eacute;s que personne ne pourra d&eacute;chiffrer sans le mot de passe ma&icirc;tre. Pas m&ecirc;me vous. Si vous oubliez votre mot de passe ma&icirc;tre, vous ne pourrez plus jamais relire ce que vous avez stock&eacute;. M&ecirc;me votre ami qui s&rsquo;y connait ne pourra rien pour vous. </p>



<p>Ne vous laissez toutefois par leurrer. On parle s&eacute;curit&eacute;, chiffrement, complexit&eacute; des fonctions de d&eacute;rivation de clef, mais en r&eacute;alit&eacute; tout &ccedil;a a peu d&rsquo;importance compar&eacute; &agrave; votre mot de passe ma&icirc;tre. C&rsquo;est un peu comme un coffre-fort&nbsp;: Discuter du diam&egrave;tre des barres de renfort n&rsquo;a aucun int&eacute;r&ecirc;t s&rsquo;il s&rsquo;ouvre avec une combinaison de trois chiffres seulement.</p>



<p>S&rsquo;il est possible de trouver votre mot de passe avec un nombre de tentatives limit&eacute;, tout le reste ne servira &agrave; rien. &laquo;&nbsp;Limit&eacute;&nbsp;&raquo; dans ce cas, &ccedil;a d&eacute;passe la centaine de milliards de combinaisons. Il vaut mieux un mot de passe ma&icirc;tre complexe avec une fonction de d&eacute;rivation simple qu&rsquo;un mot de passe ma&icirc;tre simple avec une fonction de d&eacute;rivation complexe.</p>



<h3>Changer le mot de passe</h3>



<p>Les plus alertes d&rsquo;entre vous auront remarqu&eacute; que si tout est d&eacute;chiffr&eacute; indirectement &agrave; partir du mot de passe, changer le mot de passe fait perdre l&rsquo;acc&egrave;s &agrave; tout ce qui est d&eacute;j&agrave; chiffr&eacute;.</p>



<p>Quand vous changez votre mot de passe ma&icirc;tre, Keepass d&eacute;chiffre toutes les donn&eacute;es en m&eacute;moire, calcule la nouvelle clef et rechiffre l&rsquo;int&eacute;gralit&eacute; des donn&eacute;es. M&ecirc;me si vous g&eacute;rez une centaine de mots de passe, c&rsquo;est quelque chose qui se fait rapidement sans que vous ne le perceviez.</p>



<p>Bitwarden utilise lui une clef interm&eacute;diaire totalement al&eacute;atoire appel&eacute;e clef de chiffrement. C&rsquo;est cette clef qui sert en r&eacute;alit&eacute; &agrave; chiffrer et d&eacute;chiffrer les donn&eacute;es stock&eacute;es. Elle est elle-m&ecirc;me chiffr&eacute;e, &agrave; partir de la clef ma&icirc;tresse, et stock&eacute;e &agrave; c&ocirc;t&eacute; des donn&eacute;es.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-8.50.36-1024x353.png" alt="" class="wp-image-19423" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-8.50.36-1024x353.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-8.50.36-300x103.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-8.50.36-768x265.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-8.50.36.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>On a donc un mot de passe ma&icirc;tre qui sert &agrave; calculer une clef ma&icirc;tresse. La clef ma&icirc;tresse sert &agrave; d&eacute;chiffrer la clef de chiffrement. La clef de chiffrement sert &agrave; chiffrer et d&eacute;chiffrer les donn&eacute;es sur le disque.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-15.08.18-1024x850.png" alt="" class="wp-image-19459" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.08.18-1024x850.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.08.18-300x249.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.08.18-768x637.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.08.18.png 1482w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>Lorsqu&rsquo;on veut changer de mot de passe il suffit de chiffrer la clef de chiffrement avec la nouvelle clef maitresse. Il n&rsquo;y a pas besoin de rechiffrer chaque donn&eacute;e (vu que la clef de chiffrement ne change pas, elle).</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-15.07.33-1024x586.png" alt="" class="wp-image-19457" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.07.33-1024x586.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.07.33-300x172.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.07.33-768x439.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.07.33.png 1482w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>L&rsquo;avantage n&rsquo;est pas tant dans le temps gagn&eacute; (peu significatif) mais dans la r&eacute;sistance aux acc&egrave;s concurrents&nbsp;: On peut avoir plusieurs clients qui lisent et &eacute;crivent en parall&egrave;le des donn&eacute;es diff&eacute;rentes dans le m&ecirc;me trousseau sans crainte que l&rsquo;un d&rsquo;eux n&rsquo;utilise encore une ancienne clef de chiffrement et envoie des donn&eacute;es illisibles par les autres.</p>



<h3>Et justement, et si je partage&#8239;?</h3>



<p>Avec ce qu&rsquo;on a vu jusqu&rsquo;&agrave; pr&eacute;sent, si je partage des mots de passe je dois aussi partager la clef de chiffrement utilis&eacute;e.</p>



<p>Bitwarden permet de partager des mots de passe &agrave; un groupe de plusieurs personnes (appel&eacute; &laquo;&nbsp;organisation&nbsp;&raquo;). Au lieu d&rsquo;&ecirc;tre chiffr&eacute;s avec ma clef de chiffrement personnelle, ces mots de passe sont chiffr&eacute;s avec une clef de chiffrement d&eacute;di&eacute;e &agrave; l&rsquo;organisation.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-9.02.10-1024x340.png" alt="" class="wp-image-19425" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-9.02.10-1024x340.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-9.02.10-300x100.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-9.02.10-768x255.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-9.02.10.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>Le gros enjeu n&rsquo;est pas dans le chiffrement mais dans comment transmettre cette clef d&rsquo;organisation &agrave; chaque utilisateur de l&rsquo;organisation. </p>



<p>Il faut un moyen pour que l&rsquo;administrateur de l&rsquo;organisation chiffre la clef d&rsquo;organisation, me l&rsquo;envoie sur le serveur d&rsquo;une fa&ccedil;on que seul moi puisse la relire. </p>



<p>Jusqu&rsquo;&agrave; maintenant c&rsquo;est impossible parce que nous utilisons des clefs sym&eacute;triques. C&rsquo;est la m&ecirc;me clef qui sert au chiffrement et au d&eacute;chiffrement. Si l&rsquo;administrateur pouvait chiffrer avec ma clef, il pourrait aussi d&eacute;chiffrer tous mes mots de passes personnels et &ccedil;a c&rsquo;est inacceptable.</p>



<p>C&rsquo;est donc ici qu&rsquo;on reparle des clefs asym&eacute;triques RSA. Chacun a une clef publique (diffus&eacute;e &agrave; tout le monde) et une clef priv&eacute;e (garder secr&egrave;te par chaque utilisateur). La clef publique sert &agrave; chiffrer. La clef priv&eacute;e sert &agrave; d&eacute;chiffrer. Tout le monde est donc capable de chiffrer quelque chose avec ma clef publique, mais seul moi pourrait le d&eacute;chiffrer.</p>



<p>La clef RSA fait 2048 bits mais ne vous laissez pas impressionner, ces 2048 bits sont en fait moins robustes que les 256 bits d&rsquo;AES.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-10.17.15-1024x332.png" alt="" class="wp-image-19427" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.17.15-1024x332.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.17.15-300x97.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.17.15-768x249.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.17.15.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>L&rsquo;administrateur de l&rsquo;organisation r&eacute;cup&egrave;re ma clef publique, chiffre la clef d&rsquo;organisation &agrave; l&rsquo;aide de ma clef publique, et envoie &ccedil;a sur le serveur. Quand je voudrais chiffrer ou d&eacute;chiffrer quelque chose dans l&rsquo;organisation, je r&eacute;cup&egrave;re la clef d&rsquo;organisation chiffr&eacute;e avec ma clef publique, je la d&eacute;chiffre avec ma clef priv&eacute;e, et je m&rsquo;en sers dans mes op&eacute;rations de chiffrement.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-10.30.31-1024x936.png" alt="" class="wp-image-19428" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.30.31-1024x936.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.30.31-300x274.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.30.31-768x702.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.30.31.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>Ok, mais il va me falloir s&eacute;curiser ma clef priv&eacute;e. On a d&eacute;j&agrave; les outils pour &ccedil;a, il suffit de la chiffrer&#8239;! Bitwarden la chiffre donc avec la clef de chiffrement, celle dont on a d&eacute;j&agrave; parl&eacute; plus haut.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-10.34.25-1024x350.png" alt="" class="wp-image-19429" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.34.25-1024x350.png 1024w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.34.25-300x103.png 300w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.34.25-768x263.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-10.34.25.png 1486w" sizes="(max-width: 1024px) 100vw, 1024px"></figure><p>On a donc un mot de passe ma&icirc;tre qui sert &agrave; calculer une clef ma&icirc;tresse. La clef ma&icirc;tresse sert &agrave; d&eacute;chiffrer la clef de chiffrement. La clef de chiffrement sert &agrave; d&eacute;chiffrer ma clef RSA priv&eacute;e. La clef RSA priv&eacute;e sert &agrave; d&eacute;chiffrer la clef d&rsquo;organisation. La clef d&rsquo;organisation sert &agrave; chiffrer et d&eacute;chiffrer les donn&eacute;es.</p>



<figure class="wp-block-image"><img src="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d%E2%80%99e%CC%81cran-2019-09-23-a%CC%80-15.06.26-783x1024.png" alt="" class="wp-image-19455" srcset="https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.06.26-783x1024.png 783w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.06.26-229x300.png 229w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.06.26-768x1004.png 768w, https://n.survol.fr/wp-content/uploads/2019/09/Capture-d&rsquo;e&#769;cran-2019-09-23-a&#768;-15.06.26.png 994w" sizes="(max-width: 783px) 100vw, 783px"></figure><p>Pfiou! &Ccedil;a semble long et complexe mais tout utilise toujours le m&ecirc;me principe et la plupart de ces op&eacute;rations ne servent qu&rsquo;&agrave; l&rsquo;initialisation logiciel quand vous le d&eacute;verrouillez.</p>



<p>Rappelez-vous, votre clef de chiffrement ne change pas quand vous changez votre mot de passe. Pas besoin donc de changer ou rechiffrer vos clefs RSA non plus.</p>



<h3>Et <em>Pass</em> alors&#8239;?</h3>



<p>Pass fait le choix de sauter tout le chiffrement sym&eacute;trique et de n&rsquo;utiliser que l&rsquo;asym&eacute;trique. Un d&eacute;p&ocirc;t contient les clefs GPG de tous les membres (clefs publiques). Chaque fois qu&rsquo;un mot de passe est chiffr&eacute;, il l&rsquo;est avec toutes ces clefs. Quand un membre veut lire un des mots de passe, il le d&eacute;chiffre avec sa propre clef priv&eacute;e.</p>



<p>Quand on ajoute un membre, quand on change une clef, il faut tout rechiffrer.</p>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 12c2.21 0 4-1.79 4-4s-1.79-4-4-4-4 1.79-4 4 1.79 4 4 4zm0 2c-2.67 0-8 1.34-8 4v2h16v-2c0-2.66-5.33-4-8-4z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Publié par</span><span class="author vcard"><a class="url fn n" href="https://n.survol.fr/n/author/edaspet">Éric</a></span></span><span class="posted-on"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><defs><path id="a" d="M0 0h24v24H0V0z"></path></defs><clipPath id="b"><use xlink:href="#a" overflow="visible"></use></clipPath><path clip-path="url(#b)" d="M12 2C6.5 2 2 6.5 2 12s4.5 10 10 10 10-4.5 10-10S17.5 2 12 2zm4.2 14.2L11 13V7h1.5v5.2l4.5 2.7-.8 1.3z"></path></svg><a href="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique" rel="bookmark"><time class="entry-date published" datetime="2019-09-23T12:51:10+02:00">23 septembre 2019</time><time class="updated" datetime="2019-09-23T15:10:00+02:00">23 septembre 2019</time></a></span><span class="cat-links"><svg class="svg-icon" width="16" height="16" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M10 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V8c0-1.1-.9-2-2-2h-8l-2-2z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg><span class="screen-reader-text">Publié dans</span><a href="https://n.survol.fr/dans/geek" rel="category tag">Geek</a>, <a href="https://n.survol.fr/dans/technique/securite-informatique" rel="category tag">Sécurité informatique</a>, <a href="https://n.survol.fr/dans/technique" rel="category tag">Technique</a></span>	</footer><!-- .entry-footer -->

			
</article><!-- #post-${ID} -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Navigation de l’article</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://n.survol.fr/n/quels-credits" rel="prev"><span class="meta-nav" aria-hidden="true">Article précédent</span> <span class="screen-reader-text">Article précédent :</span> <br/><span class="post-title">Quels cr&eacute;dits&#8239;?</span></a></div></div>
	</nav>
<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Laisser un commentaire		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique#respond" style="display:none;">Annuler la réponse</a></small></h3>			<form action="https://n.survol.fr/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Votre adresse de messagerie ne sera pas publiée.</span> Les champs obligatoires sont indiqués avec <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Commentaire</label> <textarea id="comment" name="comment" cols="45" rows="5" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Nom <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Adresse de messagerie <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Site web</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Laisser un commentaire" /> <input type='hidden' name='comment_post_ID' value='19406' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e7a85d6b73" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="180"/></p>			</form>
			</div><!-- #respond -->
	<form id="webmention-form" action="https://n.survol.fr/wp-json/webmention/1.0/endpoint" method="post">
	<p>
		<label for="webmention-source">J'utilise encore les commentaires mais je ne garantis pas qu'ils seront en ligne de façon permanente.

Vous êtes incités à lier et commenter ce billet depuis votre propre espace. Si votre outil gère les <a href="https://indieweb.org/Webmention">Web mentions</a> votre publication sera automatiquement référencée ici au bout d'un moment. À défaut, vous pouvez poser le lien ci-dessous.</label>
		<input id="webmention-source" type="url" name="source" placeholder="Adresse/Permalien de votre article" />
	</p>
	<p>
		<input id="webmention-submit" type="submit" name="submit" value="Faites-moi un ping!" />
	</p>
	<input id="webmention-format" type="hidden" name="format" value="html" />
	<input id="webmention-target" type="hidden" name="target" value="https://n.survol.fr/n/dis-toton-comment-ca-fonctionne-la-securite-dun-gestionnaire-de-mots-de-passe-introduction-cryptographique" />
</form>
</div><!-- #comments -->

		</main><!-- #main -->
	</section><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer">
				<div class="site-info">
										<a class="site-name" href="https://n.survol.fr/" rel="home">Carnet de notes</a>,
						<a href="https://wordpress.org/" class="imprint">
				Fièrement propulsé par WordPress.			</a>
								</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

<p style="font-size:0.8em;color:#aaa;margin:0 1em 1em 1em"><a href="https://n.survol.fr/a-propos">À propos de ce site, du contenu, de l'auteur</a><br>Je poste parfois ici des humeurs ou des pensées. Parfois je change, parfois je me trompe, parfois j'apprends, et souvent le contexte lui-même évolue avec le temps. Les contenus ne sont représentatifs que de l'instant où ils ont été écrits. J'efface peu les contenus de ce site, merci de prendre du recul quand les textes sont anciens. Merci</p>
<p style="font-size:0.8em;color:#aaa;margin:0 1em 1em 1em">À toutes fins utiles, ce site est hébergé par OVH SAS, joignable par téléphone au +33 (0)9 72 10 10 07 et dont le siège social est au 2 rue Kellermann, 59100 Roubaix, France.</p><script type='text/javascript' src='https://n.survol.fr/wp-includes/js/comment-reply.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://n.survol.fr/wp-includes/js/wp-embed.min.js?ver=5.0.3'></script>
<script async="async" type='text/javascript' src='https://n.survol.fr/wp-content/plugins/akismet/_inc/form.js?ver=4.1'></script>
	<script>
	/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>
	
</body>
</html>
